Forums :: Resources :: Features :: Photo Gallery :: Vintage Radio Shows :: Archives :: Books
Support This Site: Contributors :: Advertise


It is currently May Wed 23, 2018 12:03 am


All times are UTC [ DST ]





Post New Topic Post Reply  [ 2 posts ] 
Author Message
 Post subject: 1939 Philco- "Got it to have sound but no stations yet"
PostPosted: Feb Mon 05, 2018 6:33 am 
Member
User avatar

Joined: Jun Sun 14, 2009 10:44 pm
Posts: 441
re: https://hartford.craigslist.org/atq/d/p ... 68616.html

Happened upon this listing for a very challenged Philco, "Got it to have sound but no stations yet":
Attachment:
philco_39-45_Clist_p1.jpg
philco_39-45_Clist_p1.jpg [ 51.83 KiB | Viewed 293 times ]



Perhaps the reception problems might be because...
Attachment:
philco_39-45_Clist_p2.jpg
philco_39-45_Clist_p2.jpg [ 42.1 KiB | Viewed 293 times ]



The radio is GONE!! :shock:

Cheers,
Grid2


Top
 Profile  
 
 Post subject: Re: 1939 Philco- "Got it to have sound but no stations yet"
PostPosted: Feb Mon 05, 2018 7:10 am 
Member
User avatar

Joined: Apr Sun 01, 2012 9:55 pm
Posts: 8729
Location: Seattle area, WA
LOL. Definitely a bad choice of photos. But the seller does say in the text that the electronics are included in the sale.

He also says it needs a new 2A3 socket, which is odd because that radio doesn't use 2A3 tubes. Wonder if it has a couple 2A3s stuck in it instead of 42s? That could be a deal.
https://www.radiomuseum.org/r/philco_39_45.html

He also strangely suggests that the missing veneer could be replaced with floor tiles. :?: :?: :?: That's a 'bright' idea I haven't encountered before. Apparently he's not a woodworker.

_________________
Rodney -- KG7EPW
Measure it with a micrometer, mark it with chalk, cut it with a chainsaw.


Top
 Profile  
 
Post New Topic Post Reply  [ 2 posts ]  Moderator: Lou deGonzague

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 9 guests



Search for:
Jump to:  
























Privacy Policy :: Powered by phpBB