Forums :: NEW! Web Resources :: Features :: Photo Gallery :: Vintage Radio Shows :: Archives
Support This Site: Contributors :: Advertise


It is currently May Sat 08, 2021 12:27 pm


All times are UTC [ DST ]





Post New Topic Post Reply  [ 2 posts ] 
Author Message
 Post subject: Gulbransen model 130 cathedral style radio 1931
PostPosted: Apr Wed 09, 2014 9:39 pm 
New Member

Joined: Apr Wed 09, 2014 9:29 pm
Posts: 1
Hello,
Anyone have a schematic available for this radio? The radio just hums when plugged in. I've checked all tubes and found the # 47 tube was bad. Replaced the tube but no improvement. I've been told the problem could be one or both of the filter capacitors (tall cylindrical-looking type). Anyone have any ideas or experience with this issue?


Top
 Profile  
 
 Post subject: Re: Gulbransen model 130 cathedral style radio 1931
PostPosted: Apr Thu 10, 2014 2:57 am 
Member
User avatar

Joined: Apr Sun 01, 2012 9:55 pm
Posts: 12617
Location: Seattle, WA
Yes. That hum typically means a filter capacitor in the power supply is dead and bad things are happening in your radio that can destroy expensive and hard-to-replace components like the speaker or the main power transformer. DO NOT plug it in again until you've replaced at least the electrolytic filter capacitors in the power supply! We can help you figure out how. Caps are cheap. Speakers and transformers are not.

Welcome aboard! Lots of friendly folk here when you're ready to go for it. :D

Rodney

_________________
Rodney -- KG7EPW
Measure it with a micrometer, mark it with chalk, cut it with a chainsaw.


Top
 Profile  
 
Post New Topic Post Reply  [ 2 posts ]  Moderator: sofaslug

All times are UTC [ DST ]


Who is online

Users browsing this forum: battery-maker, flops98 and 34 guests



Search for:
Jump to:  


































Privacy Policy :: Powered by phpBB