Forums :: Resources :: Features :: Photo Gallery :: Vintage Radio Shows :: Archives
Support This Site: Contributors :: Advertise


It is currently Oct Wed 16, 2019 6:41 pm


All times are UTC [ DST ]





Post New Topic Post Reply  [ 3 posts ] 
Author Message
 Post subject: Try the Easy Fix First-Kenwood Ka-6000 No Left Channel Sound
PostPosted: Feb Thu 07, 2019 1:08 am 
Member
User avatar

Joined: Feb Fri 27, 2009 11:43 am
Posts: 1012
Location: Tucson Az
I have an old Kenwood KA-6000 integrated amp from 1969. It lost all sound from the left channel. I checked the fuses and they were good. I convinced myself that it was going to be something bad and beyond my ability to fix, so I put it away in the garage where it's languished for the last couple of years. I pulled it out today and removed the cabinet. I was thinking that perhaps there was a protection relay problem. I didn't see a relay. On a whim I cleaned all the controls with contact cleaner. The amp works beautifully now. Glad to have it back, but feel kind of dumb for not finding that a lot sooner.

_________________
Rob


Top
 Profile  
 
 Post subject: Re: Try the Easy Fix First-Kenwood Ka-6000 No Left Channel S
PostPosted: Feb Mon 18, 2019 1:14 am 
Member

Joined: Jul Sun 09, 2006 3:11 am
Posts: 6369
Location: Aurora, CO 80013
RobertL wrote:
I have an old Kenwood KA-6000 integrated amp from 1969. It lost all sound from the left channel. I checked the fuses and they were good. I convinced myself that it was going to be something bad and beyond my ability to fix, so I put it away in the garage where it's languished for the last couple of years. I pulled it out today and removed the cabinet. I was thinking that perhaps there was a protection relay problem. I didn't see a relay. On a whim I cleaned all the controls with contact cleaner. The amp works beautifully now. Glad to have it back, but feel kind of dumb for not finding that a lot sooner.

Sometimes the "low hanging fruit" approach works best like "Spritz all the controls with cleaner/lube and see what happens". Nice to see an oldie back in service.

_________________
Carpe crustulum


Top
 Profile  
 
 Post subject: Re: Try the Easy Fix First-Kenwood Ka-6000 No Left Channel S
PostPosted: Feb Tue 19, 2019 8:33 pm 
Member

Joined: Dec Fri 08, 2017 5:40 pm
Posts: 229
Location: 44141
Kenwood made some really great stuff at that time. "69 was my first year as a Kenwood rep.

_________________
Bruce Hagen


Top
 Profile  
 
Post New Topic Post Reply  [ 3 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: materialsguy and 6 guests



Search for:
Jump to:  




























Privacy Policy :: Powered by phpBB