Forums :: Resources :: Features :: Photo Gallery :: Vintage Radio Shows :: Archives
Support This Site: Contributors :: Advertise


It is currently Dec Tue 10, 2019 9:37 am


All times are UTC [ DST ]





Post New Topic Post Reply  [ 29 posts ]  Go to page Previous  1, 2
Author Message
 Post subject: Re: Philco Model 20 need suggestions.
PostPosted: Nov Fri 15, 2019 10:37 pm 
Member

Joined: Jan Thu 01, 1970 1:00 am
Posts: 1326
Location: Rome New York USA
I did some further testing of the xformers.
#2: Pri: 3-300 ohm, Sec: 5
#7 Pri: 13 ohm, Sec 5
#10: Pri 12 ohm, Sec 5 Ohm.

Ted, my tracer send noise down the line,and get noise thru the speaker from the 2nd 24 tube, thought I had it from the 1st 24, but I don't get now.

Frank


Top
 Profile  
 
 Post subject: Re: Philco Model 20 need suggestions.
PostPosted: Nov Fri 15, 2019 11:30 pm 
Member

Joined: May Fri 01, 2015 2:33 am
Posts: 1462
Location: Roslyn,Pa 19001
I'm sorry Frank I miss spoke. I should have said to measure the resistance of the ant coil pri measure from the chassis to the ant lead coming from the chassis. Volume control will vary it.
I still think 300 ohms is suspicious.
If you have a good ant just connect it to the stator of the tuning condenser. Connected to the 1st rf stage it bypasses the ant coil and vol contr kinda. Connected to the 2nd rf stage it bypasses the ant coil, and plate circuit of the 1st rf stage. Connected to the last stator only use the detector stage.
GL

Terry


Top
 Profile  
 
 Post subject: Re: Philco Model 20 need suggestions.
PostPosted: Nov Sat 16, 2019 1:26 am 
Member

Joined: Jan Thu 01, 1970 1:00 am
Posts: 1326
Location: Rome New York USA
Thanks Terry. I will place the antenna where you indicated. probably will not get to until next week, going hunting.
Thanks for you help, will keep you informed.

Frank


Top
 Profile  
 
 Post subject: Re: Philco Model 20 need suggestions.
PostPosted: Nov Tue 19, 2019 2:02 am 
Member

Joined: Jan Thu 01, 1970 1:00 am
Posts: 1326
Location: Rome New York USA
I'M back. did what you recommended Terry, placed my antenna on the 24 grids, pu a weak station on the 2nd 24, nothing on the 1st 24. Checked everything from the Primary of #7, checked ok, until I removed the #2 xformer, it has a open primary. I thought i had checked it before, but I guess not. Can I sub a resistor across the primary, will that work, tried in an IF xformer, and it worked. If I can what ohm resistor?

Thanks for all the help, feel that I am making some progress.

Frank


Top
 Profile  
 
 Post subject: Re: Philco Model 20 need suggestions.
PostPosted: Nov Tue 19, 2019 4:47 am 
Member
User avatar

Joined: Jan Tue 31, 2012 1:55 am
Posts: 10366
Location: Mountains of Mourne. Ireland.
Part No. 2 First R.F. Transformer 3884-N

Rewinding Philco RF Coils. by D. K. Owens. (Ken).
via Chuck Schwark's website:
https://www.philcorepairbench.com/rewin ... -rf-coils/

Parts list here...
viewtopic.php?p=2734937#p2734937

Greg.


Top
 Profile  
 
 Post subject: Re: Philco Model 20 need suggestions.
PostPosted: Nov Wed 20, 2019 3:36 pm 
Member

Joined: Jan Thu 01, 1970 1:00 am
Posts: 1326
Location: Rome New York USA
Thanks Greg,
The topic is informative, but will be my last resort, a little out of my capabilities, getting too old to tackle it. I just found that I have a model 20 in my stash, if I can locate it, will try to salvage a coil from it, thou with my luck it's probably bad also.

Frank


Top
 Profile  
 
 Post subject: Re: Philco Model 20 need suggestions.
PostPosted: Nov Thu 21, 2019 6:12 am 
Member

Joined: Jan Thu 01, 1970 1:00 am
Posts: 5792
Location: 253 Blanche St. Plymouth, MI USA
Do you have the large "tool shed" tube shield in place ? I am wondering about feedback between tubes here also. The models 20,21, 70, 71 and 90, 91 will not work properly without the tube shield. Found that out years ago, each time I peaked it, it would oscillate. Had to de-tune it a lot to get it to run but then it had no ears.
Mark Oppat


Top
 Profile  
 
 Post subject: Re: Philco Model 20 need suggestions.
PostPosted: Nov Fri 22, 2019 12:49 am 
Member

Joined: Jan Thu 01, 1970 1:00 am
Posts: 1326
Location: Rome New York USA
Mark,
After working on the problem a while, I remembered that I had a shield for the 24's, found it and installed, didn't make a difference. Did more troubleshooting, found the 1st rf coil open. Terry in Pa was gracious enough to rewire for me, when I get it back, hope that is the only problem. The chassis had a lot of issues, most of the caps were bad, I replaced them, and all the resistors were bad, out of tol, replaced them.
Great people on this forum, never lack for help. Thanks

Frank


Top
 Profile  
 
 Post subject: Re: Philco Model 20 need suggestions.
PostPosted: Dec Wed 04, 2019 12:38 am 
Member

Joined: Jan Thu 01, 1970 1:00 am
Posts: 1326
Location: Rome New York USA
Finally found the problem with this pain. Doing ohmic tests for correct wiring found that one cap went to ground on both terminals, opened the plastic tub that holds the cap, and found that there was a piece of wire, that I didn't see when I replaced the cap, it was shorting across the cap. I now pu stations, but have another problem, I get a station when adjusting the volume control from 18v-20v, any thing above the 20v i lose the station. The pot checks good.

Frank


Top
 Profile  
 
Post New Topic Post Reply  [ 29 posts ]  Moderators: Marcc, Norm Leal Go to page Previous  1, 2

All times are UTC [ DST ]


Who is online

Users browsing this forum: Google Adsense [Bot], philman38 and 7 guests



Search for:
Jump to:  




























Privacy Policy :: Powered by phpBB