Forums :: Resources :: Features :: Photo Gallery :: Vintage Radio Shows :: Archives :: Books
Support This Site: Contributors :: Advertise


It is currently Apr Thu 18, 2019 11:41 pm


All times are UTC [ DST ]





Post New Topic Post Reply  [ 11 posts ] 
Author Message
 Post subject: Hallicrafters S-53 receiver
PostPosted: Feb Mon 12, 2018 10:31 pm 
Member

Joined: Feb Wed 07, 2018 6:52 pm
Posts: 409
Location: Stone Mountain, GA
Been hankering to do an old tube radio for a while. Talking with my dad, he misses the S-40B we had. I do too, something about the glow of those greed dials ;)

So decided to find one to restore. The S-40B's were a bit pricey and looking at the schematic, they seemed low-end. Saw this S-53 and it looks a bit newer. So am in the midst of restoration. Missing 2 knobs and looks mostly original. A few caps and resistors were replaced probably early '60s.

Used to do a few tube radios and a lot of guitar amps (usually 6L6;s with Swiss-cheese plates.) Worked in a car radio shop mid '70s. We did a few tube radios and used NOS paper caps as clients wanted original.

Of course anything new costs money. My gear is mostly for digital stuff. So Picked up an EMC model 500 sig gen (my function gen only goes to 1 mhz) and have a Precision 660 tube tester coming. Also found a isolation transformer (nice medical-grade toroid one.)

Checked things so far. Most resistors ok, coils ohm out. B+ is low, but hope it is fried 5Y3. 18 more caps need replacing. So waiting for parts :(


Attachments:
PICT1896A.jpg
PICT1896A.jpg [ 159.59 KiB | Viewed 1455 times ]

_________________
Scott.
Powered by infinite improbability drive.
Top
 Profile  
 
 Post subject: Re: Hallicrafters S-53 receiver
PostPosted: Feb Mon 12, 2018 10:46 pm 
Member
User avatar

Joined: Jun Sun 19, 2011 2:31 pm
Posts: 6352
Make sure you follow the proper schematic and alignment instructions for your S-53 since the S-53A and its manual are more commonly found and it has a lot of differences. The S-53 uses a 2.075 Mhz. IF with a loosely coupled pair of IF transformers following the mixer while the later A model uses a more conventional 455 Khz. IF. The original S-53 design was an attempt to achieve better image rejection, especially on 6 meters, without using a tuned RF stage while the later A model traded poorer image rejection for tighter selectivity.

You will find the original S-53 selectivity is fairly broad but congratulations upon finding the less common version of this receiver.

Rodger WQ9E


Top
 Profile  
 
 Post subject: Re: Hallicrafters S-53 receiver
PostPosted: Feb Mon 12, 2018 10:56 pm 
Member

Joined: Feb Wed 07, 2018 6:52 pm
Posts: 409
Location: Stone Mountain, GA
Yes, I had assumed I could use my function gen for 455kHz. When I saw the 2.075mHz, I realized I needed an RF gen. I had planned on using harmonics for the dial calibration. Actually downloaded manual and ordered sig gen and counter before it came in. Schematic looks right so far.

Forgot, I also picked up a Heathkit S-118A frequency counter.

Should do better than the S40B. As I kid, I repaired it and never could get the top band working. I think the osc was weak but tubes were hard to get at the time (no shops near.)

Should work well enough. Maybe it will get my dad interested again and keep his mind busy..

_________________
Scott.
Powered by infinite improbability drive.


Top
 Profile  
 
 Post subject: Re: Hallicrafters S-53 receiver
PostPosted: Feb Mon 12, 2018 11:51 pm 
Member

Joined: May Sat 12, 2012 1:33 pm
Posts: 1673
Location: Rochester, NY.
Be careful, the low B+ may also be from leaky electrolytic or bypass caps. I wouldn't operate it until you can determine the cause. You don't want to burn anything up.
I would replace the filter and paper caps preemptively. Some resistors may have drifted high from age.
I liked these radios and they aren't that common nowadays. There isn't much activity on 6 meters anymore, but the lower bands should be OK.


Top
 Profile  
 
 Post subject: Re: Hallicrafters S-53 receiver
PostPosted: Feb Tue 13, 2018 12:25 am 
Member

Joined: Feb Wed 07, 2018 6:52 pm
Posts: 409
Location: Stone Mountain, GA
Already replaced electrolytics and 2 grid caps but still waiting for parts. Found a few resistors way off.

Left RF rubes out and just rectifier and final with B+ to further stages disconnected. Only had 120V (dim bulb setup). Found dead paper cap on B+ hidden under amp tube socket. Now get 290 after amp heats up.

Get clicks on amp on switching phono input. So amp and both transformers ok (now power draw is correct.)

I'd normally recap all and test. However seller said he powered up and got no sound (he's just an estate sale guy.) I wanted to see if he burnt the transformers, coils, rectifier or final amp tubes. They seem ok. Now I can wait for parts and know I don't need to order expensive or had to find parts.

Most frustrating thing is I have 2 orders stalled in the Midwest by USPS. Heck, my local driver AGAIN forgot my 47uf/450v Nichicons were in his truck.

_________________
Scott.
Powered by infinite improbability drive.


Top
 Profile  
 
 Post subject: Re: Hallicrafters S-53 receiver
PostPosted: Feb Sun 18, 2018 6:05 am 
Member

Joined: Feb Wed 07, 2018 6:52 pm
Posts: 409
Location: Stone Mountain, GA
Ok, just a few bad caps ;)

Most resistors were very close; the few that drifted were way off.

Will power up tomorrow.


Attachments:
badparts.jpg
badparts.jpg [ 232.85 KiB | Viewed 1325 times ]

_________________
Scott.
Powered by infinite improbability drive.
Top
 Profile  
 
 Post subject: Re: Hallicrafters S-53 receiver
PostPosted: Feb Tue 20, 2018 7:21 am 
Member

Joined: Feb Wed 07, 2018 6:52 pm
Posts: 409
Location: Stone Mountain, GA
Well, it came up and basically worked.

There is an AC hash/buzz all over the dial. If you tune a strong local station, it works, otherwise, most is buried under noise. The 6M band was quiet as if local osc wasn't running. I did see the AVC circuit operating and the limiter worked.

The AM/CW switch did nothing. Scratching my head I followed some wires. Followed one wire from a coil and could not see where it went. Moved it over and it came off. Then I realized I and disconnected a gimmic cap. Damn, screwed up one of those factory adjustments that is undocumented.

Turns out the gimmic was connected to the 6H6 pin 3 instead of the 6SC7 pin 3. I wrapped a turn around a lead on the right pin and the osc started working about 20khz off.

Still hash all over the dial. That and no osc on the 6M band had me thinking the osc was weak. Good strong signal that drops on each band. Figured I test the tube. It tested OK but I know this tester seems to read high. A short test showed a H-K short. Hmm, that would put AC on the osc signal.

So will order a tube and see how it goes. I'm seeing a lot of differences in the wiring and values from the Photofact schematic. Many are benine like 4.7pf instead of 5pf. Others are different wiring on the iF cans (caps to ground instead of to cathode and an extra cap across a coil.) Just found a Riders that is closer though.

_________________
Scott.
Powered by infinite improbability drive.


Top
 Profile  
 
 Post subject: Re: Hallicrafters S-53 receiver
PostPosted: Feb Mon 26, 2018 5:05 am 
Member

Joined: Feb Wed 07, 2018 6:52 pm
Posts: 409
Location: Stone Mountain, GA
Ran through the IF tuning. Seemed to help.

All I get is a lot of noise. I can hear the noise get louder across the bands as if it is receiving something. On AM band, I get a few strong stations. Weak stations seem to only be a hiss or 60hz hash. On the rest of the bands nothing recognizable. I do get a distorted FM station past the 6M band.

I don't trust the signal generator. With modulation on, it seems unstable as osc stops and starts. On external mod, once you get past about a few % mod, it become a square wave 100% mod. Have a Heathkit gen coming this week.

Turned my PC off and things are better. Now get some more AM band but only real strong stations.

Have a S-40B coming that supposedly works. Well see if it is just horribly noisy here or I have something else going on.

I did order some NOS 6BA6 tobes. One is weak. I swapped some around and things changed. Maybe one is real noisy.

Don't know where to look from here until better gear and a reference. One thing I noticed is there is an XX marked under one of the IF coils. Hmm...

_________________
Scott.
Powered by infinite improbability drive.


Top
 Profile  
 
 Post subject: Re: Hallicrafters S-53 receiver
PostPosted: Feb Tue 27, 2018 8:37 pm 
Member

Joined: Feb Wed 07, 2018 6:52 pm
Posts: 409
Location: Stone Mountain, GA
Ugh, silver mica disease :( So, 4 IF cans to rebuild.

Attachment:
silvermica.jpg
silvermica.jpg [ 225.66 KiB | Viewed 1109 times ]

_________________
Scott.
Powered by infinite improbability drive.


Top
 Profile  
 
 Post subject: Re: Hallicrafters S-53 receiver
PostPosted: Mar Sun 17, 2019 5:16 pm 
New Member

Joined: Mar Sat 16, 2019 1:00 am
Posts: 1
Hi Scott

I just picked up a very nice S-53 (non-A) that looks totally complete. This is the second one I have had. Rebuilt the 1st one and sold it and the matching TX to fund another project.

Don't have a Variac, but one is on order. Anxious to plug it in so will pick up a ceramic light bulb socket and an incandescent 60W bulb put it in series with one side of the AC cord as a ballast lamp and try firing it up later today.

This RX belonged to a long-time ham and MilCom restorer/user so it may already be recapped but I will definitely check. Ditto with the resistors. I have a nice test bench with two counters, RF gen, function gen, and digi VMs so alignment won't be a problem. I hope I don't have a case of "silver mica disease" as I have rebuilt more than my share of IFs over the years.

What's the latest on your project? Saw the last posting in mid 2018.

Vy 73
Rich K7SZ


Top
 Profile  
 
 Post subject: Re: Hallicrafters S-53 receiver
PostPosted: Mar Sun 17, 2019 6:15 pm 
Member

Joined: Feb Wed 07, 2018 6:52 pm
Posts: 409
Location: Stone Mountain, GA
Rebuilt one of the IF cans and it works.

Here, there is lots of noise and the 53 does not have good selectivity. Still when you get a station the noise picks up, Could be more SMD; I just have not had the drive to rebuild the rest of the IF cans.

I picked an S-40B that works better and have almost finished restoring it.

I was able to take the S-40B down to my dad and we played with it for a few hours. I thought it did not work when I powered it up as it was so quiet. It worked well but had an intermittent short in the AGC.

Good luck on your S-53, should work with a good antenna and where there is not lots of noise. Here I have interference every 25khz across most bands.

_________________
Scott.
Powered by infinite improbability drive.


Top
 Profile  
 
Post New Topic Post Reply  [ 11 posts ]  Moderator: Sandy

All times are UTC [ DST ]


Who is online

Users browsing this forum: AC0JL, Gary Schulz and 3 guests



Search for:
Jump to:  




























Privacy Policy :: Powered by phpBB